AnsweredAssumed Answered

ADV212 OUTPUT format problem

Question asked by yumiao on Jun 18, 2012
Latest reply on Jul 16, 2012 by DaveD

hi,

     I have got a very special err, please help me to find out the reason for it ,Thanks!

     When I used the adv202 for encode , the output format is not correct .as followed:

Colour Specification box(15 byte)

          00 00 00 0F;

          63 6F 6C 72;----colr

          01;-------------colourspace

          00;------------- reserved

          00;------------ colourspace approximation

          00 00 00 12;-----(the data should be 00 00 00 11 or 00 00 00 10,

                              but the actually output data is 00 00 00 12)

          the other data seem to be right.(the example of the output data is in the attachment,which I have delete the adv202 header,{FFFFFFF0,00000000,02040002,SIZE OF THE DATA})

the BMODE direct reg is configed 0x0000000a

the MMODE direct reg is configed 0x0000000a

the other config data is as followed: (Used 32 bits HD for data )       

addr                   write data 

32'h00057F00                         04000503,

32'h00057F04                         01001E00,

32'h00057F08                         01000388,

32'h00057F0c                         03460002,

32'hFFFF0400,                        00050005,

32'hFFFF040C,                        06400640,

32'hFFFF0410,                         020D020D,

32'hFFFF0414,                         00010001,

32'hFFFF0418,                         00000000,

32'hFFFF041C,                         002E002E,

32'hFFFF0420,                         00000000,

32'hFFFF0424,                         020D020D,

32'hFFFF0428,                         00000000,

32'hFFFF042C,                         00010001,

32'hFFFF0430,                         05000500,

32'hFFFF0448,                         00310031,

32'hFFFF044C,                        00860086,

32'hFFFF141C,                        00400040;

 



    

 



Outcomes