AnsweredAssumed Answered

BF537 EZKIT Ethernet wont run above 10MPS with new PC (intel 82579LM network card)

Question asked by PAULWRIGHT on Apr 11, 2012
Latest reply on Apr 13, 2012 by PrasanthR

Hello

 

I am using a BF537 EXKIT with a program using the ethernet that has worked well for some years.  The PCs I have used always auto negotiates a 100MPS ethernet connection.

 

I have just changed my PC to an i7 processor with an intel 82579LM network adaptor.  The new PC (and others tried with the same network adaptor) report that the EZ card is only capable of 10MPS.  Returning the the connection to my old PC the 100MPS link is still OK.

 

I have updated to the latest intel drivers and I have the latest version of DSP++ and LWIP as shipped by AD.

 

I have tried fixing the the EZ card at verious speeds using the dip switches and also tried fixing the network card a verious speeds but 10MPS is the only link speed that will work.

 

I wondered if anybody else had experienced this and if so is there a trick I am missing.

 

Thanks in anticpiation

 

Paul

Outcomes