AnsweredAssumed Answered

ADAU1701 I2S Input

Question asked by tblan4 on Apr 3, 2012
Latest reply on Apr 3, 2012 by BrettG

I am having trouble connecting I2S data from an AD1871 to an ADAU1701 evaluation board and am having two seemingly related problems: 1. I cannot get digital audio into the DSP, and 2. When trying to do so, my analog inputs and cut out.

 

I have a simple schematic just to test the connection: I am sending the same analog audio to both channels of the AD1871 as well as the L analog input of the ADAU1701.  The AD1871 is operating as the master over I2S, but when I connect the L/R, B, and Data pins to the headers on the eval board, and set all the corresponding registers for the ADAU1701, I get no digital audio and the analog audio on channel 1 cuts out.  When either the L/R or B registers are reset, or the physical wire is detached or grounded, the analog audio restores.

 

The AD1871 is connected to the ADAU1701 with single wires, all ~6 inches long.  I have tied their ground together, and both are operating off the same clock from a function generator.

 

I have attached my register settings, schematic, clock signals (top to bottom: MCLK, LRCLK, BCLK, DATA), as well as oscilloscope captures of the I2S clock signals at the header pins on the eval board (top) and at the DSP itself (probing the pins on the DSP directly) as I am concerned that they might be too dirty by the time they are reaching the DSP.

 

Thanks for your help,

Tom

Attachments

Outcomes