AnsweredAssumed Answered

AD9912 pll clock multiplier changes setting or device stops working completely

Question asked by MarkusGruber on Mar 22, 2012
Latest reply on Mar 22, 2012 by DSB

Hello,

 

I am currently  prototyping using a AD9912 DDS.

After some initial issues the device works as desired exept one strange behaviour:

 

I am using a 50MHz external clock and the AD9912's internal multiplier set to 20x. After some time (even when no new data/instruction was sent), the AD9912 switches to another clock multiplier setting (eg. to 2x, 4x or 6x) or the device stops working completely. The output frequency thus is reduced or the signal is missing completely.

 

I do not see any corresponding event that might cause this behavior. I checked and exchanged the power supply, I tried another board/device etc.

Still the same strange issue. Sometimes it happens after a few minutes of operation, sometimes it takes hours to happen.

The only thing I found out is, that the AD9912 consumes significantly less power after the internal clock is reduced.

 

First I was thinking about some hardware fault or a design issue on my board.

Since the AD9912 can be reactivated working correctly simply by re-writing the corresponding registers, to me it does not seem to be a hardware problem.

 

Has anybody some explanation for that strange behavior and probably knows the solution?

 

Thanks and regards,

Markus

Outcomes