AnsweredAssumed Answered

icc coreb compilation strange behavior stall before run task

Question asked by willrobot on Feb 23, 2012
Latest reply on Mar 1, 2012 by Smiao

Hi Steven,

 

while coding,

 

I realised that my code didn't update. I tried to add coreb debuging logs but they did not apeared when runing like it would be  a previous code. I made sure it was the corect code compiled and even changed the executable and source code name. Still the same problem.

 

I added back functions that was working before (testFFT and testFIR) and it stall before running   the icc_task_init function

 

 

./icc_loader -f -e music_dsp                                      
unhandled program header sm_debug:sm_find_session bits 00000000 localep 0 
1 (6474E551): did you link this application properly?                     
task_init_addr 3c04bd4                                                    
task_exit_addr 3c05494                                                    
sm_debug:table bits1 00000000                                             
sm_debug:table index 0                                                    
sm_debug:table bits2 00000001                                             
sm_debug:create ep index 0 srcep 0 type 2                                 
sm_debug:session 02798828                                                 
sm_debug:sm_send_packet: 0 02798828                                       
sm_debug:alloc buffer 2971400                                             
sm_debug:sm_task_sendmsg msg type 2000000                                 
sm_debug:sm_task_sendmsg init addr03c04bd4                                
sm_debug:sm_send_packet: len 332 type 2000000 dst 1 dstep 5 src 0 srcep 0 
sm_debug:sm_send_message_internal: dst 1 src 0 02000000                   
sm_debug:send message cpu 1 sent 1                                        
COREB: sm_handle_control_message type 2000000                             
COREB: sm_handle_control_message 2000000 2000000                          
COREB: task init 3c04bd4 exit 3c05494                                     
COREB: sm_send_message_internal() dst 0 src 1 2000001                     
sm_debug:sm_find_session bits 00000001 localep 0                          
sm_debug:index 0 ,local ep 0 type 2                                       
sm_debug:session 02798828 index 0 msg type2000001                         
sm_debug:sm_task_recvmsg msg type 2000001                                 
sm_debug:sm_task_recvmsg free 2971400                                     
COREB: finish sm_handle_control_message task status 1                     
COREB: finish1 sm_handle_control_message task status 1                    
COREB: before run task 3c04bd4

 

 

I've put the executable in attachement to see if you get the same result has me. Could you tell me what could cause this behavior?

 

PS: I'm not using anymore the trunk version, I'm using the icc_core that come with the uClinux release 2011R1

 

Thanks,

 

 

William

Attachments

Outcomes