AnsweredAssumed Answered

USB host on bf526-ezbrd

Question asked by illishar on Feb 22, 2012
Latest reply on Jun 13, 2013 by sonic

I'm having some trouble with usb in my u-boots. I have a custom bf526 board, but I'm using a bf526-ezbrd for reference. I would like to use a usb flash disk, to flash my fw. Eg. I would like to use the "usb start" etc. etc. and then copy some given file to some given address.

But I cannot make my u-boot recognize my usb disks. I've tried several brands and disks. No luck. I've also tried (just for the test) to attach an usb-serial-converter. But it doesn't even seem to power it up.

 

(I've been using the usb gadget drivers from within Linux and they work just fine. And I imagine that the host drivers from Linux work likewise.)

 

I'm using a small cable (I've tried several) to connect the usb mini to the usb A on the usb disk.

 

My U-boot version is: U-Boot 2010.06 (ADI-2010R1-RC2)

 

This is all it ever says:

===============================================================

usb start

(Re)start USB...

USB:   scanning bus for devices... No USB Device found

       scanning bus for storage devices... 0 Storage Device(s) found

===============================================================

 

 

What am I missing?

Outcomes