AnsweredAssumed Answered

Slightly high voltage output on AD8497.

Question asked by jdraughn on Jan 24, 2012
Latest reply on Jan 25, 2012 by Reemo

I am trying to build a DIY reflow oven and have converted a small convection oven.  Since all thermocouple conditioner/ampflier IC's on the market are surface mount I have been kind of stuck, since I need to solder the IC, but can't solder the IC until my oven is finished. However I have been able to do a few boards anyway by using my DMM with it's thermocouple input and manually turning off the oven elements to approximate the correct reflow profile.

 

One of the test boards I did was a DS600 which is a +/- 0.5ºc accurate temperature sensor.  I wanted to make sure that I could get repeatable results by manually controlling my oven before trying my $5.10 AD8497 IC.  I then designed and built a small board that contains my AD8497. I basically copied the basic connection schematic from the datasheet and used the values from the article "Two Ways to Measure Temperature Using Thermocouples Feature Simplicity, Accuracy, and Flexibility" for the input filter. I was able to solder the board succesfully using my SMD oven, so now I can work on implementing a PID controller.

 

The problem is that the measured temperature on my board is almost 4º too high.  If I ground the inputs to measure the ambient temperature, the output is nearly spot on when compared to the output of my DS600 temp sensor board.  I was originally going to use a AD8495 because the ambient temperature in my enviroment is usually always between 20º and 25º, but digikey only carried the AD8497.  But, even though my ambient temperature is about 22º I still got 22º when grounding the inputs.

 

I don't know if I can remove the 4º error in software, or if it's going to scale wrong even more as the temperature rises more.  I don't know where to go from here to further troubleshoot.

 

I could post pictures of my schematic and board if needed.  When I designed the board I used a different part in eagle with the same pinout so it's hard to follow on my schematic.  The finished board is pretty small, it's about 1" by 1.25". When I grounded the inputs so I can check ambient temperature I just used an aligator clip.

 

Thanks for your time.

 

James

Outcomes