AnsweredAssumed Answered

NAND Issues with WB cache enabled

Question asked by James.Kosin on Jan 20, 2012
Latest reply on Jun 14, 2012 by James.Kosin

Everyone,

 

I'm experiencing issues with my NAND (Micron MT29F16G08).

The nand works perfectly if I disable the WB cache on the BF-537.

I can run 'nandtest' on the device and don't get any major problems.

 

If I enable the WB cache policy in the kernel for the data, then I get problems and the 'nandtest' application always fails at some point in the test.

Unfortunately, these failures mean that if a file-system is being supported it will also fail.

 

The problem seems to be when writing data, that the Twb time when in WB mode isn't being honored.  As a result, the driver thinks the NAND is ready when in fact the 100ns timeout seems to be too short and the driver starts writing the next sector just before the NAND signals BUSY.

 

1)  Anyone else experiencing NAND issues with the WB cache enabled?

     If you don't know can you run 'nandtest' a few times to verify... and report here.

 

So far, the only way I've come up with that allows it to work with the WB cache enabled is to extend the 100ns delay to ~400ns before checking BUSY pin.

 

James

Outcomes