AnsweredAssumed Answered

Can't see ADRV9009 from Linux ZCU102 Platform

Question asked by L_R on Jul 31, 2018
Latest reply on Jul 31, 2018 by mhennerich

I have followed the instructions for creating a 2018_R1 image (2018_R1-2018_06_26.img.xz). Moved the relevant files into the root directory as described from the ADRV9009 ZCU102 directory. I get a GUI to boot after enabling the DisplayPort. Updated the Boot and the Tools with the desktop links via Ethernet.

 

I cannot get the IIO scope to see the ADRV9009 or get the PC Transceiver Eval Software to connect.

 

The ADRV9009 Eval board itself has been tried on an older ZC706 platform and works correctly. It is plugged into FMC1 HPC1 (J4).

 

Below is the output as a comparison with the Quickstart Guide (ADRV9009-W/PCBZ Zynq UltraScale+ MPSoC ZCU102 Quick Start Guide [Analog Devices Wiki] ). As you can see only the devices present on the main FMC SPI are found. During the boot "ad9528: probe of spi32766.0 failed with error -5" which is also suspect.

 

root@analog:~# iio_info | grep iio:device
        iio:device1: ad7291
        iio:device0: ams
root@analog:~#

 

root@analog:~# fru-dump -b /sys/bus/i2c/devices/16-0050/eeprom
read 256 bytes from /sys/bus/i2c/devices/16-0050/eeprom
Date of Man     : Wed Aug 30 14:05:00 2017
Manufacturer    : Analog Devices
Product Name    : 9379RC0,9528
Serial Number   : 171663006
Part Number     : 9379
FRU File ID     : Empty Field
PCB Rev         : 01B
PCB ID          : 9379CE01B
Uses LVDS       : Y

 

I have attached the DMESG output.

 

Would be grateful for some guidance on this. Thanks.

Attachments

Outcomes