AnsweredAssumed Answered

ADF5355 SPI interface does not respond after power up

Question asked by elfwise on Jul 2, 2018

Hi all,

I have a ADF5355 eval board and a custom board which is based on eval board.

I was using a microcontroller board to init. and config. the boards. There were no issues and they were working well as per specifications. 

 

Recently I connected an embedded linux system's SPI interface to control the boards. With that one I'm facing the following issues:

 

Here's my setup :

ADF5355 powered up from a separate power supply, embedded linux system is powered up from a separate power supply. The connection between ADF5355 board and embedded linux system : 5 wires with a ribbon cable( LE, SPI DATA, SPI CLK, MUXOUT, GND )

 

Issues : 

1. If I power up ADF5355 board first, it starts drawing about 200 mA (normal)

and power up the linux board later ( as soon as I apply power to linux board) ADF5355 board draws less current (160 mA). After this happened, when I write the init. sequence, the ADF5355 does not respond at all and frequency lock does not occur. The current drawn from power supply about 160 mA @6V remains same. 

 

I monitored SPI lines & LE with an oscilloscope, I didn't find significant activities on these lines, when I power up the linux board. 

 

2.I have to power down both boards, leave for about 30 seconds and power up the linux board while the ADF5355 is powered down and once the linux board is powered up & booting, ADF5355 board can be powered up and it starts drawing current about 200 mA @6V. Then once the linux boot is finished, when I run my software, it config. the frequency and frequency lock occurs and work normally. 

 

3. I removed the SPD-S board and wired the SPI & LE signals to eval. board & I checked the same thing and it happens with eval board, if I power it up before the linux board as well. 

 

I guess, there's no issues with my register configs. or sequence, as I'm using the same values and writing sequence on microcontroller and linux board and they worked well on microcontroller without issues. 

 

Does anyone have a clue on what happens here? 

 

Cheers,

Outcomes