AnsweredAssumed Answered

ADV7611 EDID Not Working

Question asked by LaserdyneRD on Jun 7, 2018
Latest reply on Jun 13, 2018 by PoornimaSubramani

Started a new question based on posts in various threads:

ADV7611: Internal EDID stays disabled 

ADV7612 to ADV7611 Configuration compatibility 

ADV7611 documented example configuration 

(ADV7611) To enable internal EDID. 

ADV7611 Design Support Files 

 

I've been trying for coming up to 2 days to get this working. Tried lots of things, lots of scripts, becoming quite frustrated. The ADV7611 is working correctly as an DVI-BT656 converter.  EDID block is being written ok, checksum seems right, port is enabled, but nothing is detected by our video source.

 

My test pattern generator (Quantumdata 882) queries IIC Addr 60, not A0 as it has been described elsewhere.  The 7611 UG may reference this, but the wording is unclear:

DDC Bus Addresses

 

Here's what I see on the DDC bus:

DDC Bus

 

 

The REP block I'm currently using is as follows:

[64]   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
------------------------------------------------------
0000 | FF FF FF FF FF 00 00 00 00 00 00 00 00 00 00 00 ................
0010 | 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
0020 | 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
0030 | 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
0040 | 81 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
0050 | 00 00 20 00 00 00 20 00 00 00 20 00 00 00 20 00 .. ... ... ... .
0060 | 00 E0 00 E0 00 E0 00 E0 00 E0 00 E0 00 E0 00 E0 ................
0070 | B9 00 41 00 01 00 01 00 00 88 00 00 00 00 00 00 ..A.............

Outcomes