AnsweredAssumed Answered

AD9884AKSZ-140 noise issue

Question asked by no11529 on Jun 6, 2018
Latest reply on Jun 13, 2018 by no11529

Hi,

Customer use AD9884AKSZ-140 and there is noise issue with input signal (1280*720). Please see the image of noise.

When they use this device for XGA, SXGA (aspect ratio 4:3 or 5:4) and WXGA(1280*768), there is no issue.

 

Do you have any idea of cause about this noise issue?

Also, is it possible to use AD9884AKSZ-140 for 1280*720(DOTCLOCK: 74.25MHz) ?

 

The condition of noise issue is below.

Input signal: 1280*720(DOTCLOCK: 74.25MHz)

Output panel: 1366*768(PANELCLOCK: 76MHzTYP)

 

Register setting is below

Function

Register

Value

PLLDIVM

00

0110 0111

67h

PLLDIVL

01

0101 0000

50h

R-GAIN

02

0110 1100

6Ch

G-GAIN

03

0110 1100

6Ch

B-GAIN

04

0110 1100

6Ch

R-OFST

05

0010 0000

20h

G-OFST

06

0010 0000

20h

B-OFST

07

0010 0000

20h

CLPLACE

08

1000 0000

80h

CLDUR

09

0000 1000

08h

General Control 

0A

0011 0000

30h

PHASE

0B

0001 0000

10h

VCO/CURRENT

0C

0100 1100

4Ch

OUTPHASE

0D

0000 0000

00h

  

0E

0000 0000

00h

  

0F

0000 0000

00h


Additional information: 

VCORNGE/CURRENT is 01/011, and customer checked 11/100 and 01/010, but there is no improvement.

Customer changed PLL setting, there are no improvement.

Customer use internal clock and they try with external clock with some frequency but there is no improvement.

When H.SYNC is stopped, the noise issue is improved. (Only scaler IC moved)

When the register of RGB OFSET is changed to lower side, the noise become easy to determine.

 

The condition without noise issue is below.

Input signal: 1024*768(DOTCLOCK: 65.0MHz)

Output panel: 1366*768(PANELCLOCK: 76MHzTYP)

 

Regards,

Attachments

Outcomes