AnsweredAssumed Answered

Application Exception "Object reference not set" Sigma Studio

Question asked by hagbrain on May 16, 2018

Hi at all,

I have a big problem and tried to fix it for hours. Now I came to the conclusion that I need help.

I used my" starter project" many times as begging for real practical projects. So it worked many times before. Now I have the following problem:

I load the project or build it from scratch that it looks like "Picture 1"/Project.dspproj.

Then I add a measurement export from REW to the upper AutoEQ in "Frequency Response". I set the target response and "Desing all". Then I close the window. Then I can send it to the chip and it work like it does. If I click again on the AutoEQ it looks like "Picture3". It looks that I havent done anything. I load the REW file again and set everything exact like before and after the "Design all" process is done, "Picture4 come up".

 

- I cant edit the AutoEQ filters again after I close the window because every time it is blank and the error appears. (If I upload to the chip, there isnt  a single filter in the DSP, only the blank AutoEQ)

- Sigma Studio 4.0 Build 2 Rev. 1759 and 3.17 Build 1 Rev. 1753, the same.

- New project or project from scratch, reinstall both or one of them and delete all folders I can find(C/Progam/x86,Roaming etc), still the same.

- I didnt install a new software or hardware.

- It worked the same way 100 times and more and then something must happen that is doesnt work now. I have no idea.

- The only way to get it working is to make a new project, load another project that didnt have the error, remove the AutoEQ  and did it again.

 

- Is there a software that come with Sigma Studio that can be damaged? Library etc?

- Is there something I can try?

- Do you need any more information?

 

Best regards

 

Michael

Attachments

Outcomes