gennyelectro

Impedance measurement with AD5933 on CN0349 dev board

Discussion created by gennyelectro on May 14, 2018
Latest reply on May 18, 2018 by isantos

Hello,

I already posted this in the discussion Three electrode measurement for AD5933? but I think to open another discussion would be more usefull.

I want to draw the Bode and Nyquist graph of the impedance of a solution with a 2 electrodes sensor. 

I am using the CN0349 development board but modified it. I replaced the AD5934 by AD5933 and removed the 1Mhz oscillator to put a programmable 1khz to 33Mhz oscillator. I would like to perform 1hz to 100khz frequency sweep. First, I changed MCLK and chose the frequencies as per the rules of thumb's table mentioned in forum Three electrode measurement for AD5933? The results were not so good, so I adjusted a little the frequencies to follow the equation: freq wanted = L * MCLK / 2^14  for L as an integer.  Still the results are not good.

I calibrated with 1kohms for a Rfb of 1kohms. I am measuring a resistor in parallel with a capacitor; 10kohms//10nF.

 

Here's the Nyquist graph for 60hz to 100khz.

The obtained phase of my circuit:

 

Every time the MCLK changes, an error is introduced. 

For the calibration, I tried using the multi-point calibration as mentioned in the AD5933 datasheet and using the Gain Factor GF for all the measuring points.  I also tried to change from the Rcal and my RC impedance, calculating the Gain Factor at each frequency and applying GF at each measurement. The results are similar.  

 

Obviously, there is something that I am missing but I cannot pinpoint it...

 

Any ideas of how to obtain a good Nyquist curve?

 

Thank you,

Genny

Outcomes