AnsweredAssumed Answered

ADV7619KSVZ hdmi input compatibility

Question asked by plushe0726 on May 4, 2018
Latest reply on May 8, 2018 by PoornimaSubramani

Hi!

       I use the ADV7619 A port, which works fine when connected to a PC graphics card(AMD Radeon HD7800).But when connected to video card HDMI output(try for two card,one uses AD9889B,another uses SiI9136-3.Both can output normally with the monitor.), it cann't work. The hotplug signal can be tested normally by oscilloscope, but there is no waveform on the TMDS clock/data lines.Schematics attached.

      In the design, ADV7619 is connected to FPGA, no external EDID eeprom.set to 1080i50 input, and the configuration file is referenced to ADV7619-VER.1.9c.txt.

      details as follows:

 

         //-5    1080/50i

  

0x98, 0xFF, 0x80, // I2C reset

  

0x98, 0xF4, 0x80, // CEC

  

0x98, 0xF5, 0x7C, // INFOFRAME

  

0x98, 0xF8, 0x4C, // DPLL

  

0x98, 0xF9, 0x64, // KSV

  

0x98, 0xFA, 0x6C, // EDID

  

0x98, 0xFB, 0x68, // HDMI

  

0x98, 0xFD, 0x44, // CP

  

0x68, 0xC0, 0x03, // ADI Required Write

  

0x98, 0x01, 0x06, // 06Prim_Mode =110b HDMI-GR  ----wwh revise

  

0x98, 0x02, 0xF5, // Auto CSC, YCrCb out, Set op_656 bit

  

0x98, 0x03, 0x80, // 24 bit SDR 422 Mode 0 ---wwh revise80 16bit

  

0x98, 0x04, 0x60, //---wwh add for 27MHz

  

0x98, 0x05, 0x2c, // 28AV Codes on  --wwh revise 2c

  

0x98, 0x06, 0xA6, // Invert VS,HS pins

  

0x98, 0x0C, 0x42, // Power up part

  

0x98, 0x15, 0x80, // Disable Tristate of Pins

  

0x98, 0x19, 0x83, // LLC DLL phase

  

0x98, 0x33, 0x40, // LLC DLL MUX enable

  

0x44, 0xBA, 0x01, // Set HDMI FreeRun

  

0x44, 0x6C, 0x00, // Required ADI write

  

0x64, 0x40, 0x81, // Disable HDCP 1.1 features

  

0x4C, 0xB5, 0x01, // Setting MCLK to 256Fs

  

0x68, 0xC0, 0x03, // ADI Required write

  

0x68, 0x00, 0x08, // Set HDMI Input Port A (BG_MEAS_PORT_SEL = 001b)

  

0x68, 0x02, 0x03, // ALL BG Ports enabled

  

0x68, 0x03, 0x98, // ADI Required Write

  

0x68, 0x10, 0xA5, // ADI Required Write

  

0x68, 0x1B, 0x08, // ADI Required Write

  

0x68, 0x45, 0x04, // ADI Required Write

  

0x68, 0x97, 0xC0, // ADI Required Write

  

0x68, 0x3D, 0x10, // ADI Required Write

  

0x68, 0x3E, 0x69, // ADI Required Write

  

0x68, 0x3F, 0x46, // ADI Required Write

  

0x68, 0x4E, 0xFE, // ADI Required Write

  

0x68, 0x4F, 0x08, // ADI Required Write

  

0x68, 0x50, 0x00, // ADI Required Write

  

0x68, 0x57, 0xA3, // ADI Required Write

  

0x68, 0x58, 0x07, // ADI Required Write

  

0x68, 0x6F, 0x08, // ADI Required Write

  

0x68, 0x83, 0xFC, // Enable clock terminators for port A & B

  

0x68, 0x84, 0x03, // ADI Required Write

  

0x68, 0x85, 0x10, // ADI Required Write

  

0x68, 0x86, 0x9B, // ADI Required Write

  

0x68, 0x89, 0x03, // ADI Required Write

  

0x68, 0x9B, 0x03, // ADI Required Write

  

0x68, 0x93, 0x03, // ADI Required Write

  

0x68, 0x5A, 0x80, // ADI Required Write

  

0x68, 0x9C, 0x80, // ADI Required Write

  

0x68, 0x9C, 0xC0, // ADI Required Write

  

0x68, 0x9C, 0x00, // ADI Required Write

        Want to know the cause of the problem and how to solve it, thanks!

Attachments

Outcomes