AnsweredAssumed Answered

Unexpected Pluto Tx Interpolation behaviour

Question asked by Richard on May 2, 2018
Latest reply on May 4, 2018 by Richard

I am using GNU Radio and the PlutoSDR blocks to control the device and am having difficulties understanding the settings for the sink interpolation and associated filtering.  The GRC flow graph is simply a sin source, rational resampled and the plutosink and I can observe the output on an Agilent spectrum analyser.  All my tests are at 430 MHz with -50 dB of Tx gain, Tx bandwidth 20 MHz and connected to the spectrum analyser.  The source sample rate is 1 MHz and the signal is 100 kHz.

 

1) Bypassing the resampler and with the sink interpolation=1, sampling_rate=1MHz, I can observe some carrier leakage and the 430.1 MHz signal as expected. (not recorded but essentially the same as in 2)

 

2) Enabling the resampler with interpolation=4, taps blank and BW=0 (this auto creates a filter), then setting the sink to 4*samp_rate; I again observe leakage + 430.1 MHz. See ExternInterp4.png. Again expected behaviour.

 

3) But bypassing the resampler, setting the sink interpolation=4 and filter=auto I observe not only the 430.1 MHz but the re-sampling artifacts at 429.1, 431.1 and somewhat lower at 428.1.  Also, it is the same output as with filter auto=False. See PlutoInterp4.png

 

4) Going back to 2, you can effectively disable filtering in the resampler by specifying taps=1 and then you observe the same output as in 3).  See ExternInterp4Tap1.png

 

So it seems to me that I am somehow not enabling the half band interpolation filters in the Pluto Tx (sink) as I would have thought from the filter=auto control.  I must be missing something, but cannot see what.  Any help appreciated.

 

 

regards Richard

Outcomes