AnsweredAssumed Answered

AD9361 no output waveform

Question asked by Nicole666 on Apr 24, 2018
Latest reply on Jun 9, 2018 by Nicole666

We met with a tricky problem。We have a set of Zynq-7000 all programmable SoC/AD9361 software-defined radio systems development kit, which is composed of OMMS3-EBZ and Xilinx ZC706, and we connect with a display to check the waveform with IIO Oscilloscope. The waveform appears normally before last Wednesday, but we can't see any waveform since last Thursday, though we did nothing to the development kit. As soon as we click on the 'run' button of the IIO Oscilloscope, the oscilloscope gets stuck and no waveform appears. Other functions of the software works well, we can read values of registers in the transceiver and can configure the parameters. Everything is good except the IIO Oscilloscope. We tried to shut down the Linux and restart the kit for many times, and we tried to write a new system into the sd card which was downloaded from the official website, which didn't work. We have measured the signal spectrum at the antenna, it seems that the transmitter works normally as configued in the software. We have read the register values of the receiver below the 'debug' lable, and they are equal to those in the 9361 register manual. We want to know where the problem lies and how to fix it.

Outcomes