rhc-29001

Issues attempting UART Slave boot in SC573

Discussion created by rhc-29001 on Apr 12, 2018
Latest reply on Apr 20, 2018 by Jithul_Janardhanan

Hi there,

 

We are trying to do load a UART slave boot by sending a .ldr file across a USB-to-UART cable as binary. We are successfully receiving the 4-byte autobaud response to suggest that the chip is ready to receive the bootstream. However, after sending ~4500 bytes, the RTS line goes high and stays high, and we are unable to finish loading it into the chip. We have tried sending at a variety of baudrates, as low as 1200 and as high as 115200, and it is always the same result.

 

We are using CCES to generate the .ldf file. It is running elfloader with the following script

 

elfload.exe -proc ADSP-SC573 -si-revision none -b uartslave -f binary -width 8 -init "C:\Analog Devices\CrossCore Embedded Studio 2.6.0\SHARC\ldr\ezkitSC573_initcode_core0" -core0="(project directory)/Debug/SC573_UART_BootMode_Application_Core0"

 

Is this an issue with our .ldf file not being in the proper format?

 

Thanks

Outcomes