AnsweredAssumed Answered

Building AD9371 HDL Reference Design  Files for ZC706

Question asked by ebray on Apr 11, 2018
Latest reply on Apr 23, 2018 by ebray

I am attempting to build the AD9371 reference design (hdl_2017_r1) following the User Guide instructions:

 

Building HDL [Analog Devices Wiki] 

 

My environment is:

WIndows 10 using Cygwin terminal

Vivado 2016.4 (most recent supported version per Releases [Analog Devices Wiki] )

 

However, when I attempt to build I receive the following errors:

 

$ git clone https://github.com/analogdevicesinc/hdl.git
Cloning into 'hdl'...
remote: Counting objects: 45514, done.
remote: Compressing objects: 100% (1116/1116), done.
remote: Total 45514 (delta 1234), reused 1146 (delta 805), pack-reused 43586
Receiving objects: 100% (45514/45514), 12.07 MiB | 7.06 MiB/s, done.
Resolving deltas: 100% (32376/32376), done.

 

$ cd hdl


$ git status
On branch master
Your branch is up to date with 'origin/master'.

nothing to commit, working tree clean


$ make -C projects/adrv9371x/zc706
make: Entering directory `/e/adi/hdl/projects/adrv9371x/zc706'
make[1]: Entering directory `/e/adi/hdl/library/axi_ad9371'
Building axi_ad9371 library [/e/adi/hdl/library/axi_ad9371/axi _ad9371_ip.log] ... FAILED\nFor details see /e/adi/hdl/library/axi_ad9371/axi_ad9371_ip.log\n
make[1]: *** [component.xml] Error 2
make[1]: Leaving directory `/e/adi/hdl/library/axi_ad9371'
make: *** [lib] Error 2
make: Leaving directory `/e/adi/hdl/projects/adrv9371x/zc706'

 

And this is the contents of axi_ad9371_ip.log:

 

/c/xilinx/Vivado/2016.4/bin/loader.bat: line 1: @echo: command not found
/c/xilinx/Vivado/2016.4/bin/loader.bat: line 2: rem: command not found
/c/xilinx/Vivado/2016.4/bin/loader.bat: line 3: rem: command not found
/c/xilinx/Vivado/2016.4/bin/loader.bat: line 4: rem: command not found
/c/xilinx/Vivado/2016.4/bin/loader.bat: line 5: rem: command not found
/c/xilinx/Vivado/2016.4/bin/loader.bat: line 8: setlocal: command not found
/c/xilinx/Vivado/2016.4/bin/loader.bat: line 10: rem: command not found
/c/xilinx/Vivado/2016.4/bin/loader.bat: line 11: rem: command not found
/c/xilinx/Vivado/2016.4/bin/loader.bat: line 14: syntax error near unexpected token `('
/c/xilinx/Vivado/2016.4/bin/loader.bat: line 14: `if [%XIL_NO_OVERRIDE%] == [1] ('

 

Can you please help me figure out what is going wrong?

 

Thanks!

Eric

Outcomes