AnsweredAssumed Answered

SC584 Ez: Boot stuck when running u-boot loaded through ICE-1000

Question asked by lunalover on Mar 30, 2018
Latest reply on Apr 26, 2018 by lunalover

Hi everyone!

I am an novice at Linux embedded development, but we have need for setting up Linux environment for ADSP-SC584 EZ Board.
(The reason is because we have to use PCIe feature, which seems supported by the corresponding driver on Linux OS only.)

But in the middle of doing following the guide document (Linux_Add-in_User's_Guide-1.2.0.pdf), we have met a problem.

In fact, from the almost outset we have been stuck.
According to the document, it guides us to load and run u-boot using ICE-1000 and GDB, and then flashing u-boot binary to SPI flash. (2.1.3 Flashing U-Boot for the First Time, Fig 1 below)

 

(Fig 1 begins ================================================)

Related part in the Linux_Add-in_User's_Guide_1.2.0.pdf

(Fig 1 ends ================================================)

 

When running u-boot loaded through ICE-1000, boot processing log begins to appear on the minicom terminal, but it shortly stops at certain but always the same point.
The point is always "Net: " as the picture below.

 

(Fig 2. Minicom terminal screen)

minicom screen

 

Our system is as below:

Host PC: Ubuntu 14.04 32 bits
CCES Linux Version: 2.6.0
Linux Add-in Version: 1.2.0

(Two members in our team tried but got the same result.
The other person used slightly different configuration, Ubuntu 16.04, CCES 2.7.0, and another EZ board. we have two boards.)

 

And, for your reference, our system picture and GDB screen are as follows.

 

(Fig 3. ADSP-SC584 EZ board and connections)

ADSP-SC584 EZ Board

 

 

(Fig 4. GDB terminal screen)

GDB Terminal screen

 

Of course, we paid attention to write "SC584" instead of "SC589" in every command line,
and set boot mode to 0 (no boot) as pointed out at the trouble shoot page in the document and mentioned by some helpers in the forum.

Is there anybody who had the similar symptom and resolved it?
Please help us pass this stuck state.

Thank you in advance.

 

Best regards,
Johnny Jeong (lunalover)

Outcomes