AnsweredAssumed Answered

Linux on KC705 with release 2017_R1

Question asked by IPrium on Mar 21, 2018
Latest reply on Mar 27, 2018 by DragosB

Hello ADI

 

I have KC705 with FMCOMMS3.

I use kc705_fmcomms2-3_2015_r2.zip from the page

AD-FMCOMMS2-EBZ Microblaze Quick Start Guide [Analog Devices Wiki] 

 

It works very well, but it's old, branch 2015_R2.

I see new branches 2016_R1, 2016_R2, 2017_R1 were done on ADI's github.

 

I built 2017_R1 Linux kernel and FPGA bitfile, but after programming FPGA, IIO Oscilloscope says: Unable to create IIO Buffer. SPI configuration read/write works correct, only data streaming is broken.

 

Questions:

(1) Why kc705_fmcomms2-3_2015_r2.zip is last for KC705? Why ADI doesn't update it?

(2) Did you check 2016_R1, 2016_R2, 2017_R1 for KC705?

(3) Should I use 2015_R2 and don't use newer branches?

 

Thank you in advance

 

Danil Shendrik, IPrium LLC

Outcomes