caugusta

AD9129-CBLTX-EBZ ADF4351 Loses Lock

Discussion created by caugusta Employee on Mar 19, 2018
Latest reply on Mar 22, 2018 by landsman

I am trying to operate a AD9129-CBLTX-EBZ Evaluation Board. After power-up and register setup, it runs fine for a few minutes but then the ADF4351 loses lock and usually does not recover until power-cycled.

I have experimented and discovered that if I keep the AD9129's PLL powered down then the ADF4351 runs fine and doesn't lose its lock. However, this doesn't solve my problem because I need the AD9129 to be fully powered up - but it does indicate that the problem is likely due to some sort of interference coming from the AD9129's PLL.

 

I am using the Quick Start Guide as best as I can, although some of the screenshots do not exactly match what I see on my screen, which sometimes prevents me from following the instructions exactly. 

I believe this is due to me having a version of the software that’s newer than when the Quick Start Guide was written.

I do not have a DPG3 - I have a FMC adapter board (AD-DAC-FMC-ADP) and an Altera Arria10GX Development board (DK-DEV-10AX115S-A) that I am planning to use for sending the vectors to the AD9129. 

At this early stage, I have been running the AD9129-CBLTX-EBZ board either on its own (without connection to the Altera Arria10 Development board) or else with the Arria10 driving the Data lines with zero values and just looping back the AD9129 clock (DCO to DCI).  I have been using a DACCLK frequency of 1600MHz.

 

Firstly, my understanding is that on the AD9129-CBLTX-EBZ Evaluation Board the ADF4351 generates a high frequency clock (1600 MHz in my case) which is delivered to the AD9129's DACCLK input pin. 

The AD9129 then divides the DACCLK frequency by 4 and outputs the result (400 MHz in my case) on the DCO output pin.  The AD9129's DCI input then expects to receive a clock signal of the same frequency as the DCO output (400 MHz).  So I don't understand why simply looping back this clock signal (DCO->DCI) is not considered a normal thing to do.  Could you please describe what IS the normal thing to do?

 

Secondly, the problem I'm having is not with the AD9129, it's with the ADF4351.  Upon power-up everything seems to start out fine, but then after running for a few minutes, the ADF4351 loses its lock and doesn't recover.  The only exception to this, as I mentioned before, is if I hold the AD9129's PLL in powerdown (via the GUI), then the ADF4351 problem does not occur.  I find this puzzling, however, since there are no signals going from the AD9129 to the ADF4351, and so I can’t understand why the state of the AD9129 would affect the ADF4351.

Also as I mentioned before, if I run the AD9129-CBLTX-EBZ Evaluation Board as a stand-alone unit (i.e. not connected to the FPGA board, and therefore with nothing driving the DCI lines), then the ADF4351 problem still occurs.

Also, it’s possible that I’m not configuring the board properly, as I’ve found the user manual to be not very clear.  Any advice would be appreciated.

Outcomes