AnsweredAssumed Answered

bfin-elf-ldr timeout when booting u-boot over UART in BF527 EZKIT

Question asked by shekharlav on Nov 28, 2011
Latest reply on Jun 27, 2012 by Aaronwu

Hi,

 

I am using 2010R1-RC4 toolchain. I was trying to load the u-boot over UART on BF527 EZ-KIT, and was unable to do it.

 

I am using ADSP-BF527 EZ-KIT LITE 1.5

 

The SW10 (UART ENABLE) switch settings were "OFF" "ON" "OFF" ON" with JP5 in default state.

The Boot Mode was set to 8 (BOOT LDR over UART1).

 

These settings are discussed at http://docs.blackfin.uclinux.org/doku.php?id=hw:boards:bf527-ezkit

 

 

 

I downloaded the u-boot .ldr file from the following link:

 

http://blackfin.uclinux.org/gf/download/frsrelease/499/8437/u-boot-bf527-ezkit-2010R1-RC2.tar.bz2

 

and used the u-boot-bf527-ezkit-uart-2010R1-RC2.ldr file

 

I fired the following command :

 

 

[root@TLL-DVITIYA TLL6527Mfirmware]# bfin-elf-ldr -l u-boot-bf527-ezkit-uart-2010R1-RC2.ldr /dev/ttyS0 -b 57600 && minicom
Loading LDR u-boot-bf527-ezkit-uart-2010R1-RC2.ldr ... OK!
Removing stale lock '//var/lock/LCK..ttyS0'
Opening /dev/ttyS0 ... OK!
Configuring terminal I/O ... OK!
Trying to send autobaud ... OK!
Trying to read autobaud ... bfin-elf-ldr: received signal 14: timeout while sending; aborting
As can be seen, I got a timeout during read autobaud.
I also tried setting the different baud rates like and 115200, 9600 , but I still got the same error.
I also followed the following link:

and did reset the board using SW16 (RESET) but still got the same error.

 

What might be the issue in this case?

 

Regards,

Shekhar

 

PS: The board boots up fine from the parallel flash when I set boot mode to 1

Outcomes