AnsweredAssumed Answered

AD193x Module in Sigma Studio For Sharc

Question asked by J_Rucker_00 on Feb 7, 2018
Latest reply on Feb 9, 2018 by DaveThib

Hi, 

 

A few years ago, our company was experimenting with SS for Sharc and we were using the AD193x module in the Hardware Configuration tree toolbox to control external codecs.  It worked quite well. I believe we were using Sigma Studio 1.0.3 at the time. 

 

We have picked up this project again and I have purchased a brand new ADSP21469 EZ Kit and have downloaded the most recent version of Sigma Studio for Sharc, but now the AD193x module does not seem to work any more.  

 

For example, I begin with creating a basic volume control schematic (using the on-board AD1939 codec).  I compile it and it runs great.  However, the moment I connect the AD193x to the USBi module in the Hardware Configuration tab, I lose all audio signal.  No matter what configuration settings I use on the AD193x, I am unable to get any audio signal to pass. 

 

Has anyone else had this problem?  Does it have to do with the newer versions of Sigma Studio?  I have tried this on both versions 3.9 and 3.16 and it doesn't appear to work with either version.  

 

 

Note: The AD193x controls do seem to communicate with the codec.  When I change different clock settings, I can see the clock settings change on an oscilloscope. I am just unable to get the codec to communicate properly with the Sharc.  

 

Thanks!

Attachments

Outcomes