AnsweredAssumed Answered

CLDP Loading Wrong Program

Question asked by epalaima on Feb 5, 2018
Latest reply on Feb 19, 2018 by Jithul_Janardhanan

Hi I am dealing with a really strange issue. I am using CLDP with the ICE-1000 to load programs onto an M25P16 Boot-Flash on a custom ADSP-21489 board. This worked, and I succeeded in loading the first program, which the chip now loads at boot. I then tried loading a second program onto the boot-flash. The CLDP gives no errors and acts as though the programming succeeded, but when I reboot the processor, it loads the first program!

 

I have tried rebuilding the 21489_m25p16_dpia project, and rebuilding the loader files for the second program, as well as ensuring that the second program is the correct one (it loads correctly when I run it via the debugger option). I also checked that the option I am changing is the -file option, which is set to the second programs loader file. 

 

After all of this the board still boots the first program. Have tried rebuilding / power cycling everything several times. Any idea what is going on here?

Outcomes