AnsweredAssumed Answered

ADV7613 on ubuntu

Question asked by rowdyroad on Jan 18, 2018
Latest reply on Jan 23, 2018 by rowdyroad

Hello. I've an issue with adv7613.

 

First of all, I have an arm ubuntu (tiny4412 SoC) with adv7613. Have no evaboard, so I've tried to configure adv7613 with  "01-01 HDMI Input_LVDS Output Port A" script from ADV7613-VER.1.1c.txt (other sections also tried, same things) through i2c with i2cset linux command.

 

Everything looks fine, but I have no any image on my LVDS panel. With my HDMI monitor is OK, so my device and HDMI is fine.

 

When I plug adv7613 Ubuntu hdmi driver does not see HDMI device plug or unplug.

 

May be It's happens cuz i didn't configurate (or my configuration is corrupt) EDID.

 

I've tried to make a HPA_MANUAL on. Did everything what write in documentation, but still no effect. Also I've check HPA state. It is 0. 

 

Plz tell me what I do wrong. Is EDID is required? Where I can find EDID for 1920 mode? Why HPA_MANUAL does not work?

 

 

I really need help. Thanks a log.

Outcomes