AnsweredAssumed Answered

AD5683R SPI destruction

Question asked by K1MGY on Jan 12, 2018
Latest reply on Jan 16, 2018 by K1MGY

AD5683 
+3.3V VDD
AT90SAMG55 processor

Mode 0 (oops!)

 

I use the AD5683R (love the internal ref) to drive an ADA4700-1 (this amplifier then provides a precise, software-configurable +-40V dc to another circuit).  By the way, a closed loop, with an ADC, sets the voltage very precisely and keeps it there.  All sweet.

 

The AD5683R shares the buss with an FTDI FT8100 LCD controller.  

 

In a previous incarnation I had driven the AD5683 with a software driver completely different than the Atmel Software Framework standard driver used for the FTDI.  Everything seemed to work OK, although I did see occasional reliability issues with the LCD touch screen.. maybe related as when the AD5683 was removed, physically, off the bus, the LCD worked fine.  

 

In the latest build, I brought in the same software driver used the the FT8100.  This simply involves defining the chip select to use a secondary GPIO line (specifically defined for use in SPI).  This is all good.. but...

 

...the magic smoke has been let out of three AD5683R devices in a row.  In all cases, the SPI bus lines of the AD5683R were found to be shorted (internally) to GND.  I caught the most recent fail in time and find that the SDI line is shorted to GND (the other lines are OK).

 

Now, I just found out that the driver was set to Mode 0.. so it's perhaps somewhat remarkable that the AD5683R even worked (for a brief time).  I have a hard time imagining, however, that anything in the device and on the buss would inject such current to release the magic smoke.

 

Still, worth asking if anyone at AD or in the user base has experienced this.

 

Unfortunately this may come down to a point-to-point wiring issue (my proto is just that).

 

Any ideas?

Outcomes