AnsweredAssumed Answered

Zedboard-FMCOMMS3 no PHY found error

Question asked by rohanrao on Dec 19, 2017
Latest reply on Dec 20, 2017 by travisfcollins

Hi everyone,

 

I am using the Digilent Zedboard with the AD9361 FMCOMMS3 evaluation board. Initially I tried out the Linux image provided with the FMCOMMS board, but I thought it would be best if I updated it before proceeding.

 

I downloaded the latest Linux image from here and followed the instructions on the site. The MD5 checksums were correct, both for the tar.gz file as well as for the actual image. I am able to boot into Linux and the various software (IIO Oscilloscope, GNURadio, etc) seem to work fine. The only issue is that I get a "eth0: no PHY found" error during the UART kernel loading, and an "Ethernet disconnected" in the Network Manager. I wish to connect to the Internet via Ethernet and have a router nearby to connect to. I have tried multiple times to get this working but now I have absolutely no idea how to continue. Any help or suggestions would be greatly appreciated.

 

A short excerpt from the log is below:

xemacps e000b000.eth: eth0: no PHY found
xemacps e000b000.eth: XEMACPS mii bus mii_probe fail.

 

Thanks and regards,

Rohan

Outcomes