AnsweredAssumed Answered

SPI Flash Boot Not Working ADSP-21489 Ez-Kit

Question asked by epalaima on Dec 17, 2017
Latest reply on Dec 21, 2017 by Jithul_Janardhanan

Hi, I am working on a project using the ADSP-21489 Ez-Kit. I am trying to load my program onto the onboard M25P16 SPI Flash using the BSP Example "Device_Programmer/Serial" (21489_m25p16_dpia). I have succeeded in generating a .ldr file for my program, and running the cldp to upload the program to SPI flash. When running cldp in the command prompt i get the following output, which seems to suggest that the programming has succeeded:

However when I set the boot mode to SPI Master Boot using the boot mode selector switch and reset the device the program fails to boot.

 

I have tried both SPI Master Boot and SPI slave boot options, as well as building the .ldr my project in both debug and release mode. I have also confirmed that all SPI connections to the M25P16 are in place on my EZ-Kit (no switches moved from default position).

 

 

What is causing this? Is there some additional configuration which needs to be done to my .ldr file? I need to confirm that SPI Master boot via an M25P16 will work for my application. Thanks!

 

 

*****UPDATE*****

I have also tried loading the parallel flash boot memory with my program and this boots successfully, so the problem is isolated to the SPI flash boot interface. 

Outcomes