AnsweredAssumed Answered

Solved DAQ2/ZCU102 ES2 problem. Now .elf download error

Question asked by cswanson on Dec 9, 2017
Latest reply on Jan 18, 2018 by CsomI

Support,

I am excited that I potentially solved my struggles with getting ES2 silicon on the zcu102 development board to compile correctly in Vivado for the DAQ2/ZCU102 HDL and No-OS git repositories branch hdl_2017_r1 using Vivado 2017.2.1.

 

I modified the hdl/projects/scripts/adi_project.tcl file.  Specifically, I changed the device to es2 and the file version from 3.0 to 2.2: 

Now it downloads to the zcu102 board without complaining about revisions to the silicon.

 

So my next problem is getting "make -C fmcdaq2/zcu102 run" to work without errors.  Here is the output:

 

[cswanson@ebkr-eosidx-d07 no-OS]$ make -C fmcdaq2/zcu102 run
make: Entering directory `/home/cswanson/zcu102/no-OS/fmcdaq2/zcu102'
xsdb ../../../no-OS/scripts/xsdb.tcl ZYNQ_PSU
attempting to launch hw_server

****** Xilinx hw_server v2017.2.1
**** Build date : Aug 9 2017-16:39:25
** Copyright 1986-2017 Xilinx, Inc. All Rights Reserved.

INFO: hw_server application started
INFO: Use Ctrl-C to exit hw_server application

INFO: To connect to this hw_server instance use url: TCP:127.0.0.1:3121

100% 9MB 1.7MB/s 00:05

Failed to download /home/cswanson/zcu102/no-OS/fmcdaq2/zcu102/sw/Release/sw.elf
Code 16 Time 1512830976926 Format {Invalid context}
invoked from within
"::tcf::eval -progress {
apply {{info} {
switch -- [lindex $info 0] {
"info" {
puts -nonewline "\r[lindex $info 1]"
}
"warning" {
puts "\n[lindex $info 1]"
}
"data" {
puts -nonewline "\r[lindex $info 1] of [lindex $info 2] complete"
}
"done" {
puts "\n[lindex $info 1]"
}
}
flush stdout
::xsdb::abort_check
}}} {::tcf::cache_enter tcfchan#0 {tcf_cache_eval {download_cache_client ::tcfclient#0::arg}}}"
(procedure "::tcf::cache_eval_with_progress" line 2)
invoked from within
"::tcf::cache_eval_with_progress $params(chan) [list download_cache_client $argvar] {
apply {{info} {
switch -- [lindex $info 0] {
"info" ..."
(procedure "dow" line 67)
invoked from within
"dow sw/Release/sw.elf"
(file "../../../no-OS/scripts/xsdb.tcl" line 47)
make: *** [run] Error 1
make: Leaving directory `/home/cswanson/zcu102/no-OS/fmcdaq2/zcu102'
[cswanson@ebkr-eosidx-d07 no-OS]$

Attachments

Outcomes