AnsweredAssumed Answered

ADAU 1701: lost I2C connection

Question asked by turborierer on Dec 7, 2017
Latest reply on Dec 11, 2017 by DaveThib

Hi at all,

 

in my application the ADAU 1701 is working as a slave with a uC. The first prototype worked properly for some days at my desk. Then some connection problems started. I had to reconnect many times until the DSP worked again. Now he is completely dead. When I looked at the I2C bus I noticed the following:

 

No debugger conected: SDA, SCL high through the pullups, so everything ok.

With debugger (official AD UDBi): SDA, SCL high but after the first connection the SCL line remaind low. (I tried the connection with the official ADAU1701 eval board were the debugger works still very well.)

In the beginning I could see a first telegramm. That became to just 3 or 4 level changes and now.... nothing.

 

I tried to disconnect the uC to have just the DSP and the debugger at the bus but that changed nothing.

 

Is there any possibility to check if the DSP is still allive? Or to make sure that the I2C unit has died?

 

Thanks in advance!

Outcomes