AnsweredAssumed Answered

AD1955`s slowly dying

Question asked by Al-x on Dec 6, 2017
Latest reply on Dec 7, 2017 by Al-x

Good day!

 

Maybe you can help or give some recomendations!

 

I trying debug audio interface with ADC -> adau1451+MCU -> ad1955 (two IC) and have some problems with last.

 

My first ad1955 die fast - it exploded)) Ok, I thought it was my problems with config adau1451/MCU (I had a lot of problems). But second IC then slowly died too. It happens in next order (events after power on, a lot of power on->off->on - rarely or often, withing some days):

1. I hear "Pffffphhssss....", than normal output signal.

2.  I hear "Pffffphhssss....", than silence...., than normal output signal.

3.  I hear "Pffffphhssss....", than silence, than slowly rising (audiodata) signal...., than normal output signal.

4.  I hear "Pffffphhssss....", than silence, than slowly rising (audiodata) signal, with clipping (signal is little, but it sounds like clipping)..., than clipping slowly go back, normal sound rising...., than normal output signal.

5. .... At the end of her life - normal sound signal go with silence (sound.....silence....signal....silence).

_____________
Now I have third sick IC, which have 4 stage of list bellow: in silence + white noise signal (no signal on ADC, but NOTE muted) at one channel it has  0.9V in the outputs, at second - 2.96V.

 

One interesting thing: if I disable SPI master at power up and start up - there is no sound exactly, and may be no "Pffffphhssss....". And only if I enable SPI and write it all zero (default value of config regs) - it start working. Like default values are not writing well by default. But I see it on sick IC - I`m not sure on good IC.

_____________

 

What can be wrong in my schematic or config?)

Today I see, that RST I connect for plus.

I attach some sch. It has transformer power with big capac..

I have a lot of time of rising and falling power suply.

Today I can`t say exactly (can do it later) temperature, but IC seem to be hot. But I found only RST and MUTE input difference of datasheet and EVB. I check PCB and they died in different places of PCB.

 

I`m going to try connect RST with RC net, but 3 IC with the same problems (bought in different places) ... it will be better for understand what happend with them and where is the problem)))

Outcomes