AnsweredAssumed Answered

Why does my Simulink freeze when i run Fmcomms3 example models?

Question asked by Samer-Alshaer on Nov 26, 2017
Latest reply on Dec 3, 2017 by Samer-Alshaer

Hello,

 

I am running into issues experimenting with the FMCOMMS3 board on the Zeboard. I am trying to execute the HIL QPSK baseband example in the link below that enables streaming data in/out to/from the board using Matlab and the Libiio library. https://wiki.analog.com/resources/tools-software/linux-software/libiio/clients/qpsk_example The Simulink model would run and build without any issues. However, after few seconds the Matlab simulation would freeze and I have to terminate the program. Also for the time the simulation runs the constellation symbols are unstable.

 

Some things I tried: - Changing the compiler: I experimented with MinGW, windows SDK 7.1, and Microsoft Visual C++ 2015 compilers. All gave the same the result.

- Execute the model on two different PCs: I tried using two different PCs using the same setup and following the same steps but I got the same results .

- Re-installing Libiio again on the linux image: I followed the "Building on the Linux Host Target“ guide under https://wiki.analog.com/resources/tools-software/linux-software/libiio but it didn’t help.

 

Some System Information: Matlab version: 2017a OS: Windows 10 Linux image: 29 june 2017 release following the guide under https://wiki.analog.com/resources/tools-software/linux-software/zynq_images Part of the process to run the model, I setup a stable connection between the linux system and the host pc.

 

After that i installed libiio exe installer from: https://github.com/analogdevicesinc/libiio/releases, v0.11. I downloaded the system object files from https://github.com/analogdevicesinc/libiio-matlab, and the example models from: https://github.com/analogdevicesinc/mathworks_tools/tree/2015b/hil_models .

 

Any help getting the model to work or reasons why it might freeze would be appreciated.

Outcomes