AnsweredAssumed Answered

AD9361 projects can not Launching with SDK

Question asked by spring1919 on Nov 8, 2017
Latest reply on Nov 13, 2017 by DragosB

Hello teacher,

         I use VIVADO2016.2 to build MICROBLAZE minimum system debugging AD9361, hardware platform is KC705, builted  9361 project with SDK2016.2, compile project error, suggesting that no-OS-2016_R2 \ ad9361 \ sw \ Reference file "#include" ../ad9361_api.h "in the console_commands folder command.c, I will  changed to" #include "ad9361_api.h, the ablove  error disappear,but has two another errors  for: no-OS-2016_R2 \ ad9361 \sw \ platform_xilinx in "platform.h file" undefine XPAR_AXI_DMAC_0_BASEADDR  and  XPAR_DDR3_SDRAM_S_AXI_BASEADDR undefined parameter.  so, I follow no-OS-2014_R2 parameter in the "CF_AD9361_RX_DMA_BASEADDR" is defined as "0x46000000", "CF_AD9361_TX_DMA_BASEADDR" is defined as "0x46000000", "ADC_DDR_BASEADDR" is defined as "0x46000000", "DAC_DDR_BASEADDR" is defined as "0x46000000",

        After changing the above file ,I compile project ,it also has  errors , prompts data overflow, I have changed address space of  "sys_dlmb_cntlr " and "sys_ilmb_cntlr"   in VIVADO , Changed  the address space from 256K to 512k, export to the hardware platform to SDK , after the SDK compiled ,no errors prompts ,and generate the .elf file,

       but there has been "No Active System" error during RUN,  How can I solve this problem that can not Launching, how to enter DEGUG interface?

     thanks teacher!

Attachments

Outcomes