AnsweredAssumed Answered

Simulink resulting standalone binary execution on AD9361

Question asked by EtanV on Nov 8, 2017
Latest reply on Nov 10, 2017 by EtanV

Hi,

 

I don't know how to resolve an issue with the standalone start of an executable binary after deploying it to my System-On-Module. My Simulink model works correctly with the AD9361 SDR 2x2 SoM and carrier board PicoZed ADRV1CRR-BOB under Simulink External mode and the automatically deployed binary to the dual-core ARM processing part of the Zynq SoC runs normally with printing the results to file from the S-Function gotofile block. I've attached photos of the model as well as all the resulting files. But when I stop the model execution and start manually the resulting binary (as a standalone application) it doesn't work as in the previous variant with its build, load, run model. It gets to

####### Resetting to DMA Source #######

message and not to

** starting the model **

########## Start Continuous Rx Transfers ##########

 

Has anyone had a similar problem? My goal is standalone execution of the resulting binary after Simulink model  embedded code build.

Within my development process I'm using:

- Matlab Version: 9.2.0.538062 (R2017a) with Simulink Version 8.9

- Communications System Toolbox Support Package for Xilinx Zynq-Based Radio

- Xilinx Vivado® development tools, version 2016.4

- Xilinx SDK development tools, version 2016.4

- Xilinx Zynq-7000 Embedded Coder

 

Thanks a lot for any ideas how to overcome this issue.

 

Etan

Outcomes