Post Go back to editing

AD7405-1 no ack on second Byte..

Hi All,

 

I'm using a AD7415-1 (I2C interface) and the timing it at 5usec or 200KHz clock.

After power up (aprox 1second) I'm not able to setup the AD7415-1 correctly.

 

Following the datasheet information I'm starting by seting up the Configuration Register using the message type shown on Figure11 of the datasheet.

 

I first Write the Serial Bus Address Byte(0xFA), followed by the Address Pointer Register (0x00) followed by the Cofiguration Register Address (0x42).

Is the above setting correct? especially the second byte..

 

The AD7415-1 acknoledges only the first byte (0xFA) but NOT the second one (0x00)..

 

Assuming the order 0xFA,0x00,0x42 is correct.. Am I missing something fundamental..?

 

Any help would be much appreciated.

 

Thanks

 

Leoad

Parents
  • Hi Leoad,

    For every write operation, after the device address byte, the register address pointer needs to be loaded into the device. This address pointer register represents the address of the register you want to read or write data. If you use the 0x00 value for the address pointer, the temperature register will be selected which is a read only register. To configure the device, please use the 0x01 value for the register pointer followed by the value you want to write to it. In this case, the sequence would be 0xFA, 0x01, 0x42.

    Regards,

    FEB

Reply
  • Hi Leoad,

    For every write operation, after the device address byte, the register address pointer needs to be loaded into the device. This address pointer register represents the address of the register you want to read or write data. If you use the 0x00 value for the address pointer, the temperature register will be selected which is a read only register. To configure the device, please use the 0x01 value for the register pointer followed by the value you want to write to it. In this case, the sequence would be 0xFA, 0x01, 0x42.

    Regards,

    FEB

Children
No Data