ADT7470 temperature reading failed

Hi,

     We are using ADT7470 and TMP05 for fans control. Now we can control PWM duty in manu mode and also can read fan tach. But when we try to get temperature from reg 0x20~0x29, we only read the temp of -92  to -102℃,our TMP05 chain has 2 device. Our operation follows the standard procedure in the datasheet, but it can't works. So,  is there any sample code for auto control mode to supply?

Best regards,

Tony.Y

Parents
  • 0
    •  Analog Employees 
    on Jan 15, 2021 8:00 AM 1 month ago

    Hi, Tony.
    Are the parts connected as in Figure 13 of the ADT7470 datasheet? And you followed the steps listed on page 14? Can you share screenshots of the interface when reading a temperature register?

    I don't have a sample code for either unfortunately but can you clarify if you're using manual or automatic fan speed control? We only have a sample code for 2 daisy-chained TMP05 parts in the TMP05 datasheet. Have you tried checking the TMP05s on their own and see what measurement you get? 

    Regards,

    Karen

Reply
  • 0
    •  Analog Employees 
    on Jan 15, 2021 8:00 AM 1 month ago

    Hi, Tony.
    Are the parts connected as in Figure 13 of the ADT7470 datasheet? And you followed the steps listed on page 14? Can you share screenshots of the interface when reading a temperature register?

    I don't have a sample code for either unfortunately but can you clarify if you're using manual or automatic fan speed control? We only have a sample code for 2 daisy-chained TMP05 parts in the TMP05 datasheet. Have you tried checking the TMP05s on their own and see what measurement you get? 

    Regards,

    Karen

Children