ADT7320UCPZ Tcrit, Thigh flags issue

I'm using the ADT7320UCPZ (rev 3) in 'Continous' Conversion mode (same issue when using One-Shot mode),
with CT and INT pin configured in 'Interrupt mode' with Activ Low Polarity.

Two ADT7320U devices share the same SPI bus, with separated chip select and SDOUT.
I'm reading the 'Temperature' register of each ADT7320 devices every second.

Issue :
 Tcrit, Thigh flasg are never set, when reading 'Status' register, or 'Temperature value' register (when 13 bits mode is selected)
 but the INT and CT pins works well

1) When the Temperature rise above the Thigh set point,  the INT pin goes low,
then on this interrupt event the software reads the 'Status' register (Addr=000) : read value is always 0x00 (D[5]=1 isexpected)
The Thigh flag is not set
in the 'Status' register !
(at this time the Temperature is still 5°C over the
Thigh set point, therefore the Status Thigh flag should be set)
the INT pin returns to the inactiv high level during 'Status' register reading (before the output of the DATA byte).

2) Same issue with the CRITICAL flag:
    When the Temperature rise above the Tcrit set point, the CRIT pin goes low,
    on this interrupt event the software reads the 'Status' register (Addr=000) : read value is always 0x00 (D[6]=1 is expected)

    The Tcrit flag is not set in the Status register !
    (at this time the Temperature is still 5°C over the
Tcrit set point, therefore the Status Tcrit flag should be set)
    the CRIT pin returns to the inactiv high level during 'Status' register reading (before the output of the DATA byte).

I never seen one of the Tcrit or Thigh flag set to 1, however the INT and CT pins works well reporting the Over Temperature events !?!