ADG884 switching issue at 80-85 Deg. C operating temperature.

ADG884 switching issue at 80-85 Deg. C operating temperature.

We are using ADG884 in data acquisition system. 

ADG884 is multiplexing two difference voltage followed by instrumentation amplifier and Delta sigma ADC. The 1st voltage is 25~50mV and 2nd voltage is 0.1~2mV. We are measuring 1st voltage every 120ms and 2nd voltage every 1.2 second. 

The system works fine at room temperature and we didn't observe any data violation during 48~72 hours repeatability test. 

We observe drift of 1~2mv drift in 1st reading and 2nd reading measurement at 80-85 deg. C of operating temperature. 

We study the characteristics of switch and its on state resistance will not cause problem to us, since it connected to buffer input of instrumentation amplifier. 

Can someone please help us to understand which parameter of switch is causing this issue?

Thanks and best regards,

Dnyandeep

    •  Analog Employees 
    on Apr 9, 2018 6:52 PM over 2 years ago

    Hi Dnyandeep,

    Sorry for the delayed response. I'm looking into this. In the meantime, I will need the following information to assess the application.

    Can you share the schematic and scope plots showing the switch response at room temp and at 80C - 85C.

    Also, have you checked the 0.05 ohm difference of on resistance from 25C to 85C? Please see figures 6 and 7, page 8 of the ADG884 datasheet.

       

    How fast do you toggle S1A to S1B? What is the frequency at IN1?

    Best Regards,

    May