Post Go back to editing

ADF5610 ADI SDP Setup Driver Error

Hello,

My customer is having ADI SDP Driver 2.4.0.286 Setup Driver issue. When they try to install they get Error (attached) Error opening File for writing: C:\WINDOWS\system32\csaDriverInterface.dll. They already tried that https://ez.analog.com/sdp/f/discussions/105352/sdp-s-windows-10-drivers.

From customer:

"Furthermore, even if we install the driver and connect to the computer, the device manager is reporting the device as USB Serial Converter A & B that uses FTDI drivers provided by Microsoft, and not the Analog Development Tools. We have tried this on several different computers and the results seem to be the same.(Pic also attached)

I was able to update the serial converters to use the ADI drivers manually as shown below, but the ADF5610 evaluation software is still unable to locate the SDP-S board. (pic attached).

DOCX

Is there perhaps an older version of the drivers? Let me know if you have any questions."

Thanks,

Anita

Parents
  • Hi Anita,

    Has the customer followed the connection procedure as outlined in the evaluation board user guide page 8?

    www.analog.com/.../EV-ADF5610SD1Z-UG-1409.pdf

    Everything the customer requires should be included in the ADF5610 software installation. Are they having any issues with this installation?

    The other question I had was, does the customer have admin rights on their machine when installing?

    Regards,

    Kieran

  • HI Kieran,

    I believe the customer has followed the procedure on multiple PC's. I have a windows 10 laptop and installed the sofware with no issues. However I don't have a board, so was wondering if you could send me a pic of what the device manager should look like after installm mine is attached, and I believe it is correct.

    I would like to verify the customer's comment on USB A and USB B, not sure why he would get this? There pic of device manager is above in original question attachments.

    Thanks,

    Anita

  • They also have the ADF5610 eval s/w installed and is fine, but tells them to try and reconnect every 40secs, but does nothing.

  • Hi Kieiran,

    I have tried installing ADF5610 evaluation software only on a fresh laptop, and it still fails to identify the board on the evaluation software as shown below. It also only comes up USB Serial Converter A & B on the device tree.

  • The error message I'm getting from the ADF5610 evaluation software

    Also I checked on the programmed values on the FTDI chip on the SDP-S using FTDI_Prog. Doesn't seem like it is programmed with any Analog Device related information. Are these values valid?

  • Kieran, I got the board, and spent some time debugging it. I followed the exact steps in the User manual, and the board was not connecting. It looks like everything is powered correctly on the ADF5610 board, but no data is going over SPI, although it is receiving power etc. I have another SDP board arriving in the morning, and will see if that is the issue. I will let you know, Thanks, Anita

  • Anita,

    I've referred to a member of the SDP team on this. Here are some points they said to note:

    1. On the PC you are having difficulty with after installation, check if the SDP drivers are listed in the control panel in programs and features. (type 'sdp' in the search when in programs and features)

    2. Ensure the SDP board is disconnected from the PC during installation and no other SDP API based software running on their PC. 

    3. If you do have these drivers installed on the machine (listed in control panel), uninstall them and try to install the drivers that come with the ADF5610 software and then repeat the same check in programs under control panel.

    Regards,

    Kieran 

  • Hi Kieran,

    I unistalled, reinstalled the SDP drivers, and followed instructions on page 8. Still no connection at Step 7: " Select ADF5610 and SDP-S board in the Connection tab and click Connect (see Figure 2)." The one thing you mentioned is "install the drivers that come with AD5610 software", no SDP drivers come with the AD5610. I installed from the link in the user manual. Do you mean different drivers?

    Thanks,

    Anita

  • Kieran,

    It was the SDP board. I have it all working now, dropping back to customer.

    Thanks, for your help.

    Anita

  • Hi Anita,

    I believe I might have the same issue. May I ask what is the problem with the SDP board? How did you fix it?

    Much appreciated.

  • Hi Eunice, There was no data going over the SPI interface on the original SDP board. I hooked it up to the scope and saw no data. I got a new SDP board, and it worked no problem. Regards, Anita

Reply Children
No Data