Post Go back to editing

EVAL-ADRV9002 and ZCU102 connectivity failure

Category: Software
Product Number: ADRV9002
Software Version: 0.25.0

Good morning,

I have set up the EVAL-ADRV9002 and ZCU102 for evaluation but I am having some trouble getting the TES to talk to the eval platform. 

My progress so far:

1) I set up following the ADRV9002 Zynq UltraScale+ MPSoC ZCU102 Quick Start Guide. Initially I tried to boot the ZCU102 using the SD card provided with the ADRV9002 eval kit, marked "R0.2 2020.12". Using this, the ZCU would not boot, I had no output on the serial port whatsoever. It did not even get as far as sending "Xilinx Zynq MP First Stage Boot Loader", PS_ERR_OUT LED was illuminated. 

2) I then imaged my own SD card with the latest version of the Analog Devices Kuiper Linux and moved the appropriate files to root as described in the instructions. 

3) Using this, the ZCU102 booted fine and I was able to control it through the serial port. The kernel boot log was not identical, but similar, to the provided example; there doesn't appear to be anything problematic in there. All LEDs on the ZCU102 and the ADRV9002 eval board were illuminated as expected. 

4) The Transceiver eval software would not talk to the device, providing the following error message:

A connection to the remote host could not be established. This might happen if the evaluation board is powered down or if the operating system did not boot properly. Check that you can connect to via PuTTY. If using a router with DHCP enabled, you may need to change the IP address to the one assigned dynamically. 

Alternatively, I sometimes get this error message:

The remote server failed to start. If you recently updated evaluation software, you may need to re-image your SD card. Otherwise, this might happen if another process is already connected to the server, or if the server executable was not loaded correctly on the platform. 
Close other programs and verify that /home/analog/adrv9001_server/resources/Adi.Adrv9001.Server/Adrv9001_C0 is present on the remote host

Pinging the device through the command line also failed, so in the serial terminal I saw with 'ifconfig' that the eth0 IP was not as expected; I manually set it to this IP address and I can now ping both the ZCU102 and my windows PC in the command line. 

5) I have worked through all the suggestions in the TES Connection Issues page ( TES Connection Issues ) and have had no luck, however the "Server Failed to Start" section appears to be leading me in the direction of the problem. 

When attempting to manually restart the server:

root@analog:/home/analog/adrv9001_server/resources/Adi.Adrv9001.Server# ./Adrv9001Server_C0_68.10.1
Unable to memory map register space (uio-0): Invalid argument

I would take a guess that the memory space is already allocated because the server has already tried to boot once, but I can't seem to get around this problem. Using ps -e provides a list which does not include any ADRV9002 process. 

Any advice on how to resolve this issue is appreciated. 

Thanks in advance,