Post Go back to editing

HMC452QS16G power consumption

Hello,

I'm using the HMC452QS16G amplifier with Vpd=5V (pin 3) and Vdd=5V (or Vs depending where in the datasheet you are). The PCB design is very similar to your evaluation board PCB, and a heat sink and a thermistor is used to monitor its temperature, which is always below 50ºC. Once powered, the supply current (Icq) is 485 mA as specified in the datasheet. When aplying a 456 Mhz RF signal of 10 dBm, well below the 31dBm maximum  rating, the supply current falls to ~250 mA. The current goes back to 485 mA when no RF is applied. Is this a normal behaviour?

Thanks in advance,

Parents
  • Hi Kagan,

    Thanks for the answer. Indeed yes, after some time of working the amplifier gets damaged, in the sense that the Idd rise to more than 600 mA (I have the power supply limited to that value, so the Vdd falls in that condition).

    I'm operating the amplifier in the following way: power applied to Vdd; 1 sec. wait; apply RF signal for 30 sec.; 1 sec. wait; Vdd removal. The RF signal are pulses of some micro sec. and they are sent with a separatation of 0.5 sec. Could you please help with this issue?

    Thanks,

Reply
  • Hi Kagan,

    Thanks for the answer. Indeed yes, after some time of working the amplifier gets damaged, in the sense that the Idd rise to more than 600 mA (I have the power supply limited to that value, so the Vdd falls in that condition).

    I'm operating the amplifier in the following way: power applied to Vdd; 1 sec. wait; apply RF signal for 30 sec.; 1 sec. wait; Vdd removal. The RF signal are pulses of some micro sec. and they are sent with a separatation of 0.5 sec. Could you please help with this issue?

    Thanks,

Children
No Data