I am trying to sequence the HMC487 with HMC980

I've used the HMC980 several times and it's a great chip.  With the amp HMC487 I can not get the drain to turn on if the gate (from HMC980) is connected.  If I add a separate negative supply to the amp gate Vd will turn on, but of course the automatic gate adjustment for the programmed current does not work.  Also the safe biasing sequencing will not then work.

The HMC980 datasheet spec's for the HMC487.  Any ideas why the gate connection to the amp is stopping the switching - I was wondering about excessive current sinking or something?  I have tried removing most of the decoupling capacitors on my test boards already,

  • 0
    •  Analog Employees 
    on Jun 1, 2016 4:39 PM

    Hi jrp_uk,

    I support the HMC487 and my colleague kkaya supports the HMC980.

    Are you working with these products on our Eval PCBs or on your own PCB?

    Has this problem occurred with just one of each device, or have you observed the problem with multiple devices?

    Regards,

    SMcBride

  • Hi,

    I have tried 2 board layouts (prototype and V1 board).  HMC980 is eval board and also my layout (which works with other AD amps eg. HMC608) – both behave the same way.

    I believe that the issue is that the HMC487 is drawing gate current above the level possible from the HMC980 as in attached experiment I did yesterday.  Comments welcome as I am having to work on a post production workaround board at the moment.

    Jeff

    SeqPAexperiments.pptx
  • 0
    •  Analog Employees 
    on Jun 1, 2016 5:55 PM

    Hi,

    Could you share your apps sch with HMC980 and HMC487?

    Could you also provide a scope shot (or several) like the one you did, with Vdig, Vgate, Vneg, Vdd curves during power up?

    Best,

    Kagan

  • Hi,

    The HMC980 is using the eval board.  The HMC980 used recommended datasheet decoupling.

    Initial power up with everything connected leads to the Vdd to amp HMC980 not switching on at all and Vgate remaining constant at a value between –0.4 and –0.8V (different for different HMC487 devices, different gate leakage current?).  With Vgate supplied using an external voltage supply (obviously not sequencing then) the amp works ok and the HMC980 will switch and the enable function works as expected.

    The experiment up in this thread has Vdig pulsed (Vdd constant), Vdd to amp O/C, Vgate as described.

    I can set the kit up again, but I would appreciate if you could let me know what you are looking for in the signals Vneg – that’s the charge pump pin right?  Vdd will be zero with maybe a few very high freq spikes, Vgate constant –ve voltage as above, Vdig as shown on previous slide - top trace.

    Jeff

  • Hi,

    I measured voltage at Vneg pin as you suggested and added to previous traces.

    Vdd is fixed at 0V.  The other curves you can see hopefully on the other slides.

    Jeff

    SeqPAexperiments.pptx