ADF5610 VCO Sub Band settings

Hello,

I am little bit struggling to find out the correct VCO sub band for a particular frequency for ADF5610.

I am totally unable to get any frequency in autocalibration mode, though I have followed the correct sequence of register writing.

I have followed the page no. 49 of ADF5610 datasheet and got the exact (8Ghz) Frequency.

However, I have got doubt that, how the frequency 8GHz falls under sub band 205.

I want help for selecting VCO sub band for a particular frequency.

Can any expert please explain so that I can move forward with the programming issue.

Thank you

  • 0
    •  Analog Employees 
    on Feb 22, 2021 11:54 AM

    Hi,

    Are you using the EV-ADF5610SD1Z customer evaluation board?

    At present, using this board configuration and customer software, the subband information is not available to be read back. To select a frequency for a particular subband you would need to be able to readback the subband first. 

  • Hi,

    No, I am not using the evaluation board.

    As I told you, that in auto calibration the frequency is not locked at all. So there is no point to read the registers without lock condition.

    However, I got succeed in manual calibration mode by putting the sub band values directly.

    Kindly suggest.

  • 0
    •  Analog Employees 
    on Feb 24, 2021 6:38 PM in reply to RF_Expert

    Just to clarify, the sub band value of 205 is just used for example purposes. The sub band for 8GHz can vary from part to part. Therefore, before using manual calibration, you need to have read back the corresponding sub band at the desired frequency after doing an autocalibration first at that frequency.

    I have followed the page no. 49 of ADF5610 datasheet and got the exact (8Ghz) Frequency.

    However, I have got doubt that, how the frequency 8GHz falls under sub band 205.

    In the above quote, the first line appears as though you have performed manual calibration with sub band 205 and got 8GHz locked?  But this conflicts with the second line. Can you clarify please?

    Please share the details of the loop filter and programming sequence you are using. 

  • Dear Kieranb,

    I think you did not understand the problem well.

    Autocalibration does not function at all in my case. That is why I am going for manual calibration mode. 

    There is no point to read the registers when I am not getting any output....

  • 0
    •  Analog Employees 
    on Feb 26, 2021 8:57 AM in reply to RF_Expert

    Hi,

    Yes I understand the problem. But you need to do an autocalibration first to obtain the VCO band settings for the frequency of interest. Then you can use the band setting to perform a manual calibration. As stated on p23 of the datasheet: 

    So you would need to get autocalibration working first and get the frequency to lock using this method. 

    Regards,

    Kieran.