EV1HMC321ALP4E-SP8T switch Broken after one time measurement

Hello
I bought two switches EV1HMC321ALP4E (EVAL BOARD FOR HMC321ALP4E). I could measure them only once. And then both of them broken. it is the VDD that broken (I know because the DC power supply indicator goes red after broken and no RF output  ). Would you please tell me or replace me the product? I used ESD protection band in hand always. 
I found Another SP8T switch-part number , price is higer 1127-3263-ND, EV1HMC322ALP4. Would you please say why its price is different?  is better that no problem with broken.
 
I need to solve it in urgent.
Would you please help me regarding this problem.
 
Thanks
Afreen
  • 0
    •  Analog Employees 
    on Aug 21, 2019 9:07 AM over 1 year ago

    Hi,

    What measurement have you done before the parts are broken? Have you ever applied high logic to any of control inputs when Vdd supply is not powered up? if yes ESD protection diodes connected from control inputs to Vdd could be forward biased and damaged. This could be why Vdd draws excessive current. 

    Best.

  • Hi Thanks for your reply. No I did not apply any high logic input to control input A, B, C.  I applied 1.8 Volt to VDD and current was 5 mA from DC power supply. I grounded all Control input A,B,C . So, that I get output from RF1. Initially I get the RF output. But later Vdd broken. Now increased current from 5 ma to 100 mA of Vdd power supply, still no output and red indicator in DC power supply. 

    By the way, if I keep control input A,B, C, open, instead of low(ground), While I apply 1.8 Volt to VDD, is their any chances of broken?

    Thanks

  • +1
    •  Analog Employees 
    on Aug 21, 2019 9:37 AM over 1 year ago in reply to Afreen

    Hi,

    HMC321A was fully tested and specified with nominal Vdd supply of 5V. It can still be operated down to 3V supply but there will be degradation in large signal performances. However HMC321A may not be functional and reliable when it is powered with 1.8V supply. 

    We don't recommended to leave control inputs open when Vdd supply is applied as there is no internal pull up/down resistor.

    Best.

  • Hi

    Thanks for your reply. For the first one , I applied 5 V at Vdd.  for the 2nd one, I increased Vdd voltage gradually. I found it started to work from 1.8 volt. I increased voltage before broken and didnt found much change in output, prpbably input voltage is below 1 V. after broken, I increased voltage to 5 Volt, but still not working.

    Yes it is true that at beginning they all  worked. So  testing time it is found ok. but later it breaks. first one worked one day, and next day found broken, and 2nd one broken on same day.

    I understand that control input shouldn't be left open. 

    Thanks

  • By the way, I bought it from Digikey. Is there any service from Analog device to replace me the switches. If not is okay. but if there is, will be glad to know.

    Thanks.