ADAR1000 EVALZ -some questions about the software

Dear,

When I use software,Operating as follows:

Take the receive channel

Put through power supply,+3.3V and -5V 

1、 ,click the connect

2、 ,The operation is shown in the figure,and click the write

3、 The operation is shown in the figure,and click the write,The current is 30mA

4、 ,The operation is shown in the figure,then ,click the LDRX OVR,the current is 70 mA,Shouldn't it be 230mA?

When I click the start, ,the current is 230mA,WHY??

I also want to know ,What is the relationship between rx control and RX registers,One is register control,and the other is?Whether they work simultaneously or separately

Parents
  • +1
    •  Analog Employees 
    on Jun 17, 2019 6:01 PM

    With the 70 mA, it sounds like you only have one Rx channel enabled.  Try writing 0x3860 using the Manual Register Write tab.  I've noticed a bug in the GUI when using the Memory Control section.  But also, you have the bias currents set to 10, 5 and 8; nominal bias currents should be 2, 5, and 8.  I think there may be a binary-to-decimal mix-up for the VGA bias in the datasheet.

    I do not know why the current jumps to 230 mA while using Beam Sequencer.  I'll look into this.

    The RX Registers tab directly controls the gain, phase, memory indices, and bias currents.  Gain can be set with the VGA and the vector modulator.  Using Table 13, 14, 15 and 16 in the datasheet to set the phase, will keep the gain constant.  Note that you limit the phase resolution if you use these table, but you gain a constant gain over the 360 degrees and only have to worry about the gain via the VGA settings.  Also, the user has to think about what I & Q vector values correspond to their desired phase when using the RX Registers tab.

    Using the Rx Control tab, does all the phase calculations for you.  You pick your desired phase, and the SW will appropriately write the I & Q vectors to the phase registers.  And then you set the VGA gain, just like the in the RX Registers tab, selecting the gain index and attenuation bit.

Reply
  • +1
    •  Analog Employees 
    on Jun 17, 2019 6:01 PM

    With the 70 mA, it sounds like you only have one Rx channel enabled.  Try writing 0x3860 using the Manual Register Write tab.  I've noticed a bug in the GUI when using the Memory Control section.  But also, you have the bias currents set to 10, 5 and 8; nominal bias currents should be 2, 5, and 8.  I think there may be a binary-to-decimal mix-up for the VGA bias in the datasheet.

    I do not know why the current jumps to 230 mA while using Beam Sequencer.  I'll look into this.

    The RX Registers tab directly controls the gain, phase, memory indices, and bias currents.  Gain can be set with the VGA and the vector modulator.  Using Table 13, 14, 15 and 16 in the datasheet to set the phase, will keep the gain constant.  Note that you limit the phase resolution if you use these table, but you gain a constant gain over the 360 degrees and only have to worry about the gain via the VGA settings.  Also, the user has to think about what I & Q vector values correspond to their desired phase when using the RX Registers tab.

    Using the Rx Control tab, does all the phase calculations for you.  You pick your desired phase, and the SW will appropriately write the I & Q vectors to the phase registers.  And then you set the VGA gain, just like the in the RX Registers tab, selecting the gain index and attenuation bit.

Children