ADAR1000 Eval board PA_BIAS not working

Hi,

I have got the evaluation board for ADAR1000 and I was trying to generate PA_BIAS using the internal DAC, but not able to do so. I am interfacing the board with the software provided from you. I am following the below table from the datasheet:

I tried all the combinations described above in the GUI to generate some voltage on the pin 23 of connector P9A on the board which corresponds to PA_BIAS1. But I see nothing at all on the multimeter. 

On the GUI, these are the steps I followed in order:

1. Connect to the board using ADDR0/1 = 0 (jumpers are left open)

2. Initialized TX on the tab "Tx Control"

3. Wrote some values to off and on registers shown below and enabled BIAS_CTRL

4. Enabled TX_EN under T/R Control tab

5. Checked the multimeter on pin23 of connector P9A, to see nothing.

I also tried with LNA_BIAS_OUT feature but also seeing no output voltage. 

Am I missing something here?

Regards,

Neelesh

Parents Reply Children
  • Hi,

    After getting it to work with the eval board, I now am trying to interface the eval board with zynq fpga board. I have wired the SPI lines from the zynq board to the SPI lines on P3 connector of ADAR eval. I removed the SDP connector. Powered up the board. Then did the following sequence of reg writes:

    (Please note that this below log is taken from the ADAR eval software, the sequcnce below shows how I got the PA_BIAS output working. Now, I do the same sequence of reg writes from the FPGA board, after restarting the board and disconnecting the SDP connector)

    00:27:09: 00018 written to part
    00:27:09: 02F47 written to part
    00:27:09: 03142 written to part
    00:27:09: 03406 written to part
    00:27:09: 0363E written to part
    00:27:09: 03B40 written to part
    00:27:09: 01C7F written to part
    00:27:09: 02036 written to part
    00:27:09: 02136 written to part
    00:27:09: 02802 written to part
    00:27:09: 02800 written to part
    00:27:17: 03140 written to part
    00:27:24: 03040 written to part
    00:27:32: 02946 written to part
    00:27:32: 02A00 written to part
    00:27:32: 02B00 written to part
    00:27:32: 02C00 written to part
    00:27:32: 02D00 written to part
    00:27:36: 00000 written to part
    00:27:45: 03860 written to part

    I have verified the SPI lines from FPGA using an oscilloscope and made sure all the housekeeping rules are followed like explained in this other post https://ez.analog.com/rf/f/q-a/103841/adar1000-eval-automated-control-via-spi/317562

    I have also checked that the ADDR0/1 are stuck at 0. And the PA_EN GPIO is stuck at 0.

    After doing all this, I would have expected to see the PA1_BIAS voltage change to 1.5V but it did not change. Maybe I missed something? Can you please help?

    Thanks