Post Go back to editing

AD8339 SDP Panel Error 110005

Category: Software
Software Version: 2.1.0.17

Hi everyone,

I'm using AD8339 Eval board with SDP breakout board and SDP-B board to connect to my laptop, which has been installed SDP Panel.

I connect the board as required :

but every time when I click "connect", it reports a error SDPERROR110005 (Picture below). All drivers are installed, and the LED light is green on the SDP-B board.

My laptop recognizes the device as "Blackfin USB Device", which seems right. but this error occurs no matter with or without USB connection or power supply.

 

really don't know what to do. Anyone can help please?

  • Hi MCJ14, I support the SDP boards. I'll work with you and somebody from the AD8339 team to try to resolve this.

    Do you have a screenshot of the Windows Device Manager when you plug in the SDP-B?

  • Hi David, sorry for the late reply and thank you for your help.

    Below is the screenshot of Device Manager, you can see the device is correctly recognized.

    Besides, I forgot to mention another strange thing about this board, every time when I turn on the power supply, there's a long period (maybe 20 minutes to 1 hour) before I get some response on the oscilloscope. Is it normal or I can do sth to trigger the board to make it get started faster?

    I also attach a photo of the hardwares, maybe helpful for your diagnose.

    Thank you again!

  • Hi, I'm not familiar with this Eval Board at all. Is the software that you are using the same software that was supplied with the Eval Board?  I've looked at the datasheet and it does not mention using an SDP board to drive the Eval Board. In fact it looks like an evaluation setup that was in use before the SDP platform was introduced. Newer boards that use the SDP API have an EEPROM which holds an Eval Board ID number so that the software can recognize the board.

  • Hi, thank you for the information.

    Actually I'm dealing with the setup from a former colleague, I received the software and other documentations from him and he said it worked before. The original box doesn't hold a CD or something like that, so sorry that I'm not sure if the software is correct.

    But it seems that I happened to connect the board with a default ID, here're screenshots, does this mean it's succesflly connected? It's so weird because the Eval Board still has no response yet, or the communication between SDP and PC has nothing to do with the Eval Board?

    Thanks a lot!

  • Hi,

    So that ID is for a breakout board. The software will look for that board and will find the breakout board and there won't be any more SDPERROR110005. But the SDP Panel is a very basic generic debug tool. It is not the original evaluation utility for using this AD8339 board. It recognises the breakout board and that's it - any further communication with the board is limited to you manually typing in register addresses and data and clicking send.

    The SDP Panel, the SDP-B and ADI ACE software are all part of a newer generation of Evaluation software and hardware and as far as I can see the AD8339 was never brought onto that platform.

    If you need to configure this board and use it you can try to find the original AD8339 specific software (that uses the USB port rather than an SDP-B etc) but it is very old. You may have compatibility issues on more modern PCs. I can try to contact someone with a copy of the original software if you want to do this.

    If the serial interface was a standard interface, I would suggest writing your own code using Arduino, Raspberry Pi or an Mbed enabled MCU board. The 20 bit interface used for the AD8339 may present an issue.

    Best advice I can give is to find out more about how your setup worked in the past and what you need it to do for you this time.