LT8410-1 Booster Circuit Current Draw

Hi,

I'd like to get some support regarding Linear's LT8410-1 boost converter. 

More specifically I am measuring a large disrepancy between simulated current consumption (using LTspice) and the reality of my circuit. 

To be more precise the boost converter is set to convert about 3.4V to 13.25V or 26.5V. I am measuring about 150uA current drawn from my supply in the first case and about 3mA in the second case. LTspice simulates an average current draw of ~130uA in the first case and about 250uA in the second case. 

The situation is a bit more complicated but I would like to discuss this in private if possible with one of the support engineers.

Thank you for any support.

Parents
  • Hello Dulcevida,

    Thanks for the quick answer. Please check my schematic below:

    The intention is the following:

    From a source that varies from 3.4 to 4.2V produce an HV_BIAS voltage that can be switchable between 53V and 105V. This is achieved by boosting the voltage of the source to either 17.6V or 34.5V (with LT8401) and then using 3 voltage doubling stages utilizing capacitor/diode doubling.

    Power is fed from connector P1. Connector P3 is there for me to check the difference between connecting the output to CAP or VOUT and see the efficiency improvement. Transistor Q2 is used to switch in an 100K resistor so that selection between 53 and 105V can be done.

    The circuit using the LT6106 is used for automatic overcurrent protection. The intention is that if an overcurrent event occurs, the output of LT6106 will drive the gate of Q1 high and effectively shutdown the LT8401. /SHDN is also driven by an MCU pin so that the MCU can control the part in ON/OFF.

    Capacitors C22,C23,C28,C23,C27 are shown as 50V but I have also tried 100V.

    Inductor L5 is MURATA part no LQH3NPN251MGRL

    P6 is used to connect a trimmable load.

    I am also attaching LTSpice simulation model.

    Prototype circuit behaviour is the following:

      1.  When operating at 53V with NO LOAD, the current drawn by the circuit is measured as about 138uA. This is as expected per simulation and datasheet.

      1.  When operating at 105V with NO LOAD, the current drawn by the circuit is measured as 3.33mA. This is way off what is shown by simulation and datasheet.

    I have tried the following to find out what is the case:

      1.  Change capacitors C22,C23,C28,C23,C27  from 50 to 100V in case of leakages

      2.  Removed D6 (which is not actually needed)

      3.  Tried connecting the output to CAP or VOUT via P3

      4.  Measured the resistance from various nodes to GND to check if there is a low impedance path (due to PCB manufacturing etc). Could not find anything low enough to justify the circuit consumption.

    I would be grateful if you could provide some support on this. If you need layout files it would be ok for me to provide.

    Thank you for your help.

    Best regards,

    Vasileios

Reply
  • Hello Dulcevida,

    Thanks for the quick answer. Please check my schematic below:

    The intention is the following:

    From a source that varies from 3.4 to 4.2V produce an HV_BIAS voltage that can be switchable between 53V and 105V. This is achieved by boosting the voltage of the source to either 17.6V or 34.5V (with LT8401) and then using 3 voltage doubling stages utilizing capacitor/diode doubling.

    Power is fed from connector P1. Connector P3 is there for me to check the difference between connecting the output to CAP or VOUT and see the efficiency improvement. Transistor Q2 is used to switch in an 100K resistor so that selection between 53 and 105V can be done.

    The circuit using the LT6106 is used for automatic overcurrent protection. The intention is that if an overcurrent event occurs, the output of LT6106 will drive the gate of Q1 high and effectively shutdown the LT8401. /SHDN is also driven by an MCU pin so that the MCU can control the part in ON/OFF.

    Capacitors C22,C23,C28,C23,C27 are shown as 50V but I have also tried 100V.

    Inductor L5 is MURATA part no LQH3NPN251MGRL

    P6 is used to connect a trimmable load.

    I am also attaching LTSpice simulation model.

    Prototype circuit behaviour is the following:

      1.  When operating at 53V with NO LOAD, the current drawn by the circuit is measured as about 138uA. This is as expected per simulation and datasheet.

      1.  When operating at 105V with NO LOAD, the current drawn by the circuit is measured as 3.33mA. This is way off what is shown by simulation and datasheet.

    I have tried the following to find out what is the case:

      1.  Change capacitors C22,C23,C28,C23,C27  from 50 to 100V in case of leakages

      2.  Removed D6 (which is not actually needed)

      3.  Tried connecting the output to CAP or VOUT via P3

      4.  Measured the resistance from various nodes to GND to check if there is a low impedance path (due to PCB manufacturing etc). Could not find anything low enough to justify the circuit consumption.

    I would be grateful if you could provide some support on this. If you need layout files it would be ok for me to provide.

    Thank you for your help.

    Best regards,

    Vasileios

Children
No Data