Post Go back to editing

LT4295 - 40W Flybackmode issue

Hi,

This is Juan José Frutos, Electronic Lead designer from Sensia Solutions.

We have designed a PoE board based on the typical applications (page 21 of LT4295 Datasheet) and on the DC2539A board.

We recieved the final board, and in a first test seems to work properly, but in a more in deep testing in long times the design seems to fail. I guess due to a bad configuration of the ITHB or FB31 resistors the LT4295 start some protection mechanisim.

We have mainly the same circuit as in p21 of the LT4295 using PCA EPC3634G as T1. Snubbers were a bit different but after the failure we modify them in order to have the same design as in the typical application circuit. But failure still happeing.

This is our proceduring for testing the design:

1. Put a 90W capable PoE PS connected to our design.

2. Check the output voltage of the flyback seems correct at 11.98V.

2. Conect an electronic load configured to load 2.5A at 12V.

3. Start the load. (here I can see that the output voltage with load goes to ~11.3V).

4. After a while (~one hour) T1 and L1 are quite hotter than ussual and seems that the system start some protection mecanisim (guessing PG and HSGATE are shut down)

I would like to know, if this can be a bad configuration of ITHB and FB31, as I said we used the same values of the p21 of the LT4295 datasheet. I don't know if we should decrease the 6.65K resistor that is in series with the 2k reistor of the FB31 loop or change any resistor or capacitor in the ITHB. Can you give us any clue about this issue?

Please find attached our schematic page for your reference.

Thanks in advance,

Best regards,

Juanjo